Double‐Check Your Swift Coding Environment

By Jesse Feiler

One of the most commonly asked questions new Swift developers ask is, Can I use an old Mac to develop with Swift (or ObjectiveC or Cocoa or Cocoa Touch)? The answer depends on how old your Mac is. In most cases, Macs dating back as much as five years tend to be usable with current development tools.

What does need to be updated when you start developing — at least in many cases — is your operating system. This shouldn’t be too much of a challenge: For the last few years, the operating system updates have been free. If you don’t have the latest operating system, just download a free copy and get started.

The memory and disk requirements of the operating systems have been relatively stable. Sometimes, you may need to upgrade memory or disk storage — particularly if you’ve accumulated a lot of files on your disk(s).

Xcode is the development tool used here. It, too, is free, and most of the time you won’t need to upgrade your computer to run it. It’s true that you may want to upgrade your computer to get added speed for your development efforts, but you often can manage with a slightly slower computer for your development.

In fact, many developers find that they need powerful Macs only to help them prepare their app graphics. The code is often not a challenge, even for old computers.

There is one environmental point to attend to. With today’s large disks, everyone tends to have a lot of files floating around. Developers can easily accumulate version after version of a project’s files until it’s no longer clear which is which. The solution to this is to create a file organization system and adhere to it.

You may think you’ll remember which is the latest version of a file, but this isn’t always the case. Sometimes you can forget as soon as you’ve finished your cup of coffee. Organize your files as if they were going to be used by a whole staff of developers, and you’ll be in good shape.