Network Basics: Changing Device Boot-Up Configuration
Cisco Networking: Interface Configuration Mode
Working with Routing Information Protocol (RIP)

Viewing Single Smartport Macro Details

To see the details for only a single Smartport macro, like cisco-desktop, rather than displaying all the macros every time, use the name option. To display just the cisco-desktop macro:

Switch1> enable
Switch1#show parser macro name cisco-desktop
Macro name : cisco-desktop
Macro type : default interface
# macro keywords $access_vlan
# Basic interface - Enable data VLAN only
# Recommended value for access vlan should not be 1
switchport access vlan $access_vlan
switchport mode access
# Enable port security limiting port to a single
# MAC address -- that of desktop
switchport port-security
switchport port-security maximum 1
# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable
# Remark all inbound data packets with COS=0 & DSCP =0
mls qos cos override
blog comments powered by Disqus
Wireless Network Routing with Multiple Access Points (APs)
Cisco Password Retry Lockout
Spanning Tree Protocol (STP) Introduction
Running Router Setup Wizard
How Spanning Tree Protocol (STP) Manages Network Changes
Advertisement

Inside Dummies.com