Configuring Routing for the ICND1 and ICND2 Certification Exams

Part of the 1,001 CCNA Routing and Switching Practice Questions For Dummies Cheat Sheet

When you're preparing for the CCNA routing and switching certification exam, you'll need to be familiar with popular commands that deal with static routing and routing protocols, such as RIPv1 and RIPv2. Consider the following:

Command(s)Result
Ip routing Enables routing on the router. Should be on by default.
No ip routing Disables routing on the router.
Show ip route Displays the routing table.
Ip route 23.0.0.0 255.0.0.0 22.0.0.2 Adds a static route to the router for the 23.0.0.0 network and sends any data for that network to the 22.0.0.2 address (next hop).
No ip route 23.0.0.0 255.0.0.0 22.0.0.2 Deletes the static route from the routing table.
Ip route 0.0.0.0 0.0.0.0 22.0.0.2 Sets the gateway of last resort on the router to forward any packets with unknown destinations to the 22.0.0.2 address.
ROUTERB>enable
ROUTERB#config term
ROUTERB(config)#router rip
ROUTERB(config-router)#network 26.0.0.0
ROUTERB(config-router)#network 27.0.0.0
Configures the router for RIPv1. RIP is a dynamic routing protocol that is used to share routing information with other routers running RIP. In this example, RIP will share knowledge of the 26.0.0.0 and the 27.0.0.0 networks.
ROUTERB>enable
ROUTERB#config term
ROUTERB(config)#router rip
ROUTERB(config-router)#network 26.0.0.0
ROUTERB(config-router)#network 27.0.0.0
ROUTERB(config-router)#version 2
To configure the router for RIPv2 you use the same commands but add the "version 2" command at the end.
show ip protocols Used to display what routing protocols are running on the router.
debug ip rip Used to enable RIP debugging which will display RIP related messages on the screen as RIP related events occur (packets are sent and received).
No debug all Turns off debugging once you are done troubleshooting RIP.
#configure the trunk link on switch
  interface fa0/4
  switchport mode trunk

#configure router on stick
interface fa0/0.20
 encapsulation dot1q 20
 ip address 192.168.20.1 255.255.255.0

interface fa0/0.10
 encapsulation dot1q 10
 ip address 192.168.10.1 255.255.255.0
Configures router on a stick so that you can route traffic between systems connected to different VLANs on the same switch. High level steps are:
1. Connect router to switch
2. Configure port on switch as trunk port
3. Configure Subinterfaces on the router, one per VLAN.
  • Add a Comment
  • Print
  • Share
blog comments powered by Disqus

SERIES
1,001 CCNA Routing and Switching Practice Questions For Dummies Cheat Sheet

Advertisement

Inside Dummies.com