Cisco Switch Setup Wizard Execution

If you unpack your switch and plug it in, you will be running the generic factory configuration, the setup wizard. This configuration is enough to allow you to use the switch on the default VLAN — vlan 1 — and will have all auto options enabled for each port.

There will not be a management interface for Telnet or SSH; but once a management IP is configured, you can connect with Telnet and the web browser to make configuration changes. The complete configuration is shown here:

Switch1>enable
Switch1#show running-config
Building configuration...
Current configuration : 723 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
(Omitted for brevity)
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
ip http server
!
line con 0
line vty 5 15
!
!
end

When you first unpack a new switch or if you have erased the configuration, when the switch boots for the first time, it will automatically enter setup. If your switch does not, you have the option of running setup from Privileged EXEC mode. Here is the basic setup process; within just a few minutes, you can have the management interface on your switch up and running:

Switch>enable
Switch#setup
         --- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: yes
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:
  Enter host name [Switch]: Switch1
  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: secretpass
  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: enablepass
% Please choose a password that is different from the enable secret
  Enter enable password: enable
  The virtual terminal password is used to protect
  access to the switch over a network interface.
  Enter virtual terminal password: termpass
  Configure SNMP Network Management? [no]:
Current interface summary
Interface            IP-Address    OK? Method Status                Protocol
Vlan1                unassigned    YES unset  administratively down down
FastEthernet0/1      unassigned    YES unset  up                    up  
FastEthernet0/2      unassigned    YES unset  up                    up  
FastEthernet0/3      unassigned    YES unset  up                    up  
FastEthernet0/4      unassigned    YES unset  down                  down
FastEthernet0/5      unassigned    YES unset  down                  down
FastEthernet0/6      unassigned    YES unset  down                  down
FastEthernet0/7      unassigned    YES unset  down                  down
FastEthernet0/8      unassigned    YES unset  up                    up  
FastEthernet0/9      unassigned    YES unset  up                    up  
FastEthernet0/10     unassigned    YES unset  up                    up  
FastEthernet0/11     unassigned    YES unset  up                    up  
FastEthernet0/12     unassigned    YES unset  up                    up  
Enter interface name used to connect to the
management network from the above interface summary: vlan1
Configuring interface Vlan1:
  Configure IP on this interface? [no]: yes
    IP address for this interface: 192.168.1.241
    Subnet mask for this interface [255.255.255.0] :
    Class C network is 192.168.1.0, 24 subnet bits; mask is /24
Would you like to enable as a cluster command switch? [yes/no]: no
The following configuration command script was created:
hostname Switch1
enable secret 5 $1$HXb6$RZPOXPyDvYuOWOhvYUP1d.
enable password enablepass
line vty 0 15
password termpass
no snmp-server
!
!
interface Vlan1
no shutdown
ip address 192.168.1.241 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
(Omitted for brevity)
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
end
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection: [2]
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.
Switch1#
00:09:12: %LINK-3-UPDOWN: Interface Vlan1, changed state to up
00:09:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
(Omitted for brevity)
Switch1#

Notice how little information you need to enter to get basic management access to your switch over the network. This includes Telnet access to switch.

After the setup wizard is complete, enter Configuration mode to update your configuration to disable Telnet in favor of SSH (as a secure option) and configure your other network interfaces.

blog comments powered by Disqus
Advertisement

Inside Dummies.com