Online Test Banks
Score higher
See Online Test Banks
eLearning
Learning anything is easy
Browse Online Courses
Mobile Apps
Learning on the go
Explore Mobile Apps
Dummies Store
Shop for books and more
Start Shopping

Cisco Switch Configuration using Web Console

The GUI tool, Web Console is provided to assist you in configuring your Cisco switches. The Configuraton menu is available from the Dashboard which is the tool's main page. The Configure navigation menu has four options, Smartports, Port Settings, Express Setup, and Restart/Reboot.

This menu gives you access to the main settings that you will likely want to configure on your switch.

Smartports

Because port configuration requires a bit of knowledge, Cisco simplified the process by creating Smartports, which are preconfigured settings you can easily apply to your switchports. The figure below shows you what the Smartports configuration looks like through the web GUI. You select the type of port you want to apply and then select the ports to which you want to apply this configuration.

image0.jpg

Smartports are really just a series of macros (which you can modify) that Cisco has preconfigured on your switch. The mysterious engineers at Cisco determined that for most networks, these base configurations for ports make a lot of sense.

It is a bit of an all-or-nothing in that you can use Smartports to do your configuration, or you can do all of the configuration by hand; however, if you do some by hand, your configuration may be overwritten or incompatible with other Smartport configurations. The following table summarizes the Smartport roles that you will find on your switch.

Smartport Roles
Smartport Role Description
Desktop Suitable for access devices, such as desktop computers and printers. Implementation increases security on your network ports. This role is not suitable for routers and switches.
Cisco Switch Configures the port in Trunk mode with the other connected device that is expected to be a switch.
Cisco Router Configures settings that are compatible with a network router.
Cisco Phone + Desktop Compatible with Cisco IP phones. Because phones have built-in switches to support a desktop connection and the IP phones typically operate on different VLANs and have QoS configured, these ports have special configuration requirements.
Cisco Access Point If you are using Cisco IOS 12.2 or later, this role can be used for access points that you may have on your network.
None Removes all custom settings from the port.

The following code shows you the settings that are applied for each one of these types of ports in the order they are applied. Note that the configuration on the port even shows you which macro runs to apply the setting.

Although you have not yet looked at all these settings, spend a few minutes reviewing the changes that are made to the ports in each of these configurations. Note that trunk ports are used for the router, access points, and switches.

interface FastEthernet0/4
 switchport mode access
 switchport port-security
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
mls qos cos override
 macro description cisco-desktop
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/5
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface FastEthernet0/6
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-router
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!
interface FastEthernet0/7
 switchport mode access
 switchport voice vlan 1
 switchport port-security
 switchport port-security maximum 2
 switchport port-security aging time 2
 switchport port-security violation restrict
 switchport port-security aging type inactivity
 mls qos trust device cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/8
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-wireless
 spanning-tree bpduguard enable
!

The Smartports page also has a Recommended System Setup check box. By selecting this check box, the macro will modify the default configuration on your switch to ensure that the following settings are in place. (Note: Someone at Cisco decided that these changes are important to an operating network. Although this decision may be debatable, these settings will not hurt your networks.)

errdisable recovery cause link-flap
errdisable recovery interval 60
udld aggressive
spanning-tree mode rapid-pvst
spanning-tree loopguard default
macro global description cisco-global

Port Settings

The Port Settings page allows you to configure your port settings as shown in the following figure These settings include the Speed and Duplex settings. Port settings also give you an easy way to set a description on your ports. Descriptions help you avoid configuring incorrect ports and make you pay close attention when making changes. Finally, you have the option to enable or disable a port here, which is the same as issuing the shutdown or no shutdown command.

image1.jpg

Express Setup

The Express Setup settings give you an easy way to configure the management interfaces for your switch. These interfaces include the management interface, VLAN, IP configuration, and password. Other settings include the switch name and methods of making remote connections, such as Telnet, SSH, or http.

image2.jpg

Restart and Reset

Finally, you finish the “Configure” section with the Restart and Reset page. This page allows you to restart the switch, which is needed from time to time, but more importantly, here you can reset the switch back to the factory configuration. Even though performing this action from the command line is not too difficult, Web Console is even easier.

blog comments powered by Disqus
Advertisement

Inside Dummies.com

Dummies.com Sweepstakes

Win $500. Easy.